Sound doesn't switch automatically

Rarity

Take that, you ruffian!
Pronouns
She/her
MarioWiki
MiracleDinner
When I plug in or take out headphones it doesn't automatically switch. (Win10)
 

Redshift

Eats dinner at 10pm, wrestles Debulls
Wiki Administrator
Poll Committee
Pronouns
She/her
MarioWiki
Ray Trace
Are you using Realtek HD audio manager?

1615498787707.png


are you also trying to change through here?
 

Rarity

Take that, you ruffian!
Pronouns
She/her
MarioWiki
MiracleDinner
1615499103713.png


I can change using this interface but my problem is that i currently have to do this manually every time i change between headphones and just letting my pc play out loud, which is very annoying as i do that a lot and if i forget it could end up in things playing out loud at high volume in very bad situations, so ideally i'd like to fix this so that whenever i plug in or take out headphones it automatically changes. it worked a few days ago but then it suddenly stopped changing automatically and i haven't been able to find a solution thus far.
 

Redshift

Eats dinner at 10pm, wrestles Debulls
Wiki Administrator
Poll Committee
Pronouns
She/her
MarioWiki
Ray Trace
I'm not sure if it has anything to do with the most recent Windows update. Have you tried updating your audio driver? Or uninstalling and reinstalling your audio driver?
 

Revin

Ace Detective
MarioWiki
Reverse Input
Do you have something like "Realtek Audio Manager" installed? I've had a similar issue (it won't swap over unless i press a specific text prompt that pops up in notifications), and I think there may be some settings that you can fiddle with to see if it changes anything. If you do have it, open it up and click the little gear icon near the box in the bottom left-ish, that opened some settings for me which seemed to recreate the issue you have (specifically, ticking the top one).
Screenshot 2021-03-12 092555.png
 

Rarity

Take that, you ruffian!
Pronouns
She/her
MarioWiki
MiracleDinner
Do you have something like "Realtek Audio Manager" installed? I've had a similar issue (it won't swap over unless i press a specific text prompt that pops up in notifications), and I think there may be some settings that you can fiddle with to see if it changes anything. If you do have it, open it up and click the little gear icon near the box in the bottom left-ish, that opened some settings for me which seemed to recreate the issue you have (specifically, ticking the top one).
View attachment 10363
I don't have "Realtek Audio Manager" but I have "Realtek Audio Console". I don't see anything in there that can help me though

1615581349989.png

1615581375511.png
 

Revin

Ace Detective
MarioWiki
Reverse Input
hmm, alright. in that case, i'd probably echo BLOF's suggestion to update and/or uninstall and reinstall the audio drivers. you can probably find a download of them from the website of your computer's maufacturer (i.e. if you own a HP, go to HP's website, if you own Lenovo, go to Lenovo, etc).
 

Rarity

Take that, you ruffian!
Pronouns
She/her
MarioWiki
MiracleDinner
Somehow this fixed itself.
 
Top